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Dear Friend,

Hello & welcome back to Firewire, your friendly guide to the exciting world
of web-design & web-solutions! In this newsletter we are going to make a
buttons menu with sub buttons in it. Each button in the menu is having a
animated drop down menu for sub buttons.A mouse click on the button will
result in the fall of the sub buttons drop down and any click on the scene or
on other button will cause the reverse animation of the previous drop down
menu.

Click here to download the source (.fla) file.

Click the below given menu buttons randomly
to see how the drop down menu works

Buttonl Button2 Button3
| Sub Button 1
| Sub Button2 |
| Sub Button3 |

Movie Properties

1. Create a new movie with dimensions of 550px X 400px and fps=30 with
white as background color.

Frame Rate: |3III 'i‘ps 0k

widh Height
Dimensions: |E60px 0 [400 p

Cancel

Save Default
Match  Printer | Contents | ——

Background Colar: _I_:I

Ruler Urits: [ Pivels = ~ Help |

For the menu we have to create total six buttons.i.e. one main button and
remaing five as sub buttons
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Creating Button

1. Choose Insert > New Symbol
2. Create a movie clip and name it as 'button panel'

Symbol Properhies

Hame; Il:uuth:un panel 0K I
Behaviar. & Movie Clip Cancel |
" Button
™ Graphic Hel |
Oeip

3. Select rectangle tool in the tool box and draw a rectangle.
4. Give a gradient color fill to the rectangle.

5. Choose Insert > New Symbol
6. Create a new button and name it as 'Buttonl1’

Symbol Properties

Harme: ibuttu:un‘l K.
Behaviar tovie Clip Cancel
i Butior

* Graphic Help

.

7. Select the frame 1 in 'Button1’ button.

8. Select Window > Library > button panel movie clip

9. Drag the button panel movie clip from the library into the button1 at
the center.

|% Scenel g buttonl
oy ﬁ O | | Ue | Ower|Dowr] Hit |

[+ B ol | BN T T S

10. Rename the layer as button panel.
11. Select frame4 at Hit stage.
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12. Choose Insert > Frame.

13. Insert a new layer (Choose Insert > Layer) above the button panel
layer.

14. Type 'Button1’ text on this layer.

15. Choose Window > Panels > Text Options.

16. In the Text Options panel keep Use Device Fonts option on.
(it helps to keep font crisp).

EA Text Options .._._:

I Static Text __v_'

@Jse Device Fonts
Selectable

|Bu|ehan1

17. Select the 'Button1' text.
18. Choose Insert > Convert to Symbol.
19. Create a movie clip and name it as 'button 1 text'.

Symbol Properties ﬁ
Marne: il:uutt-:un'l bt ak.
Behavior &+ Movie Clip Cancel

£ Button
" Graphic Help

20. Rename Layer 2 as button 1 text.

21. Select frame 2 at Over stage.

22. Choose Insert > Keyframe.

23. Select button1 text movie clip at frame?2.

24. Choose Window > Panels > Effect

25. In the Effect panel change the Tint of the button 1 text movie clip.

|Butfoni



http://
http://
http://
http://
http://
http://
http://
http://
http://
http://
http://
http://

http://www.layoutgalaxy.com

http://www.layoutgalaxy.com

. Insert a new layer (Choose Insert > Layer) below the button 1 text

layer.

. Select Window > Library > button 1 text movie clip.

. Drag the button 1 text movie clip on newly added Layer 3.

. Choose Window > Panels > Effect

. In the Effect panel change the Tint of the button 1 text movie clip

and make it white.

. Keep this white tinted button 1 text movie clip slight down and

slight left.

Buttonl

Now your button is ready.Similarly you have to create remaining
5 buttons i.e. Sub Buttonl,Sub Button2,Sub Button3,Sub Button4 and
Sub Button5. Create these buttons and give them names accordingly.

Creating Drop Down Menu Movieclip

32
33

Symbol Properties

4 ame; idrnp down ok
Behavior #:Mwi’a'ﬂih Cancel

" Button .

£ Graphic Help

. Choose Insert > New Symbol
. Create a movie clip and name it as 'drop down'

i

. Select Window > Library > Sub Button1 button.
. Drag the Sub Button1 button from the library into the drop down

movie clip at the center.

. Rename the layer as sub buttonl.

. Insert a layer (Choose Insert > Layer) below the sub button1 layer.
. Select Window > Library > Sub Button2 button.

. Drag the Sub Button2 button from the library into the drop down

movie clip at the center.

. Rename the layer as sub button2.
. Similarly drag remaining buttons from the library into the

drop down movie clip at the center and place them on
separate layers.

}@ Scenel [ dop down

& 9 0|f]
[ sub buttonl « + B
[ sub button2 + @
[ sub button3 + o ]
[ sub buttond |
B :ub buttonS + N
[+ o ||t
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42. Select frame 5 on all the layers.

43. Choose Insert > Keyframe.

44. Select frame 5 on sub buttonl layer.
45. Move the Sub Buttonl downwards.

Ié Scene 1 IE‘ drop down
a0 B o
B :ub buttond ! ..
[& sub button? + = W1,
[P sub button3 + o+ [lls
[ sub buttord = = [lls
sub buttons + = [,
& B ¢ ‘almf @ cf]
Sub Bfrtton2
Sub Buttoni

46. Similarly select frame 5 on other layers and shift the respective
buttons downwards on those particular layers.

47. Arrange all the buttons in such a way that we can see them in
decending order.

+
Sub Buttonl

Sub Buttond
Sub Button3
Sub Button4
S5ub Buttans

48. Select any frame between 1 and 5 on all the layers.

49. Choose Insert > Create Motion Tween.

50. Now arrange the layers in such a way that the first keyframe of the
sub button 2 layer appears below the last keyframe of the sub
button 1 layer.

51. Also arrange other layers accordingly.

52. Select frame 25 on all the layers.

53. Choose Insert > Frame.

I'éﬁcene'l l:iupl:lmvm
;O Ol s G T ST

[ sub buttond « + [0

[ sub button? « = [, s

(2 sub button3 + =+ [, [y

L sub buttand « + [l e

' sub buttons

=) |
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54. Select the first keyframe on the sub button 2 layer.

55. Move the Sub Button 2 button downwards so that it come exactly
behind the Sub Button 1.

56. Select the first keyframe on the sub button 3 layer.

57. Move the Sub Button 3 button downwards so that it come exactly
behind the Sub Button 2.

58. Similarly arrange other buttons' positions.

59. Insert a new layer (Choose Insert > Layer) above all the layers and
rename it with 'actions'.

60. Select frame 1 on actions layer.

61. Choose Window > Actions.

62. In the Frame Actions panel type the following action.

stop ();

[ Frame Actions| 2l
ﬂ:]f Frame Actions -l A[
Fictions = Etop O
Operatars
Functions
@ Propesties
@] obiects |
4
Lira 10f 2, Cal 1
z &

63. Select frame 25 on the actions layer.

64. Choose Insert > Blank Keyframe.

65. Choose Window > Actions.

66 .In the Frame Actions panel type the following action.

stop ();

Now our sub buttons menu is ready.We have to give actions to the
button1 to see the animated drop down menu

Assigning Actions to Button

67.Now come back into the main scene i.e. Scene 1.
68.Rename the Layerl as 'drop down'
69.Select Window > Library > drop down movie clip.

70.Drag the drop down movie clip from the library at drop down layer.

71.Choose Window > Panels > Instance.
72.In the Instance panel type the Instance name as menul.

E'._—_}Instancgl ()
LEE._erp.d{:wn
Eleha-.'iar:-l Mewie Clip ;I

Tame: ]menu1

25l & || A
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73. Insert a new layer (Choose Insert > Layer) above the drop down
layer and rename it as buttonl.

74. Select Window > Library > button1 (button)

75. Drag the button1 button from the library on the layer named as
buttonl.

76. Place the drop down movie clip exactly under the button1 so that it
can look proper.i.e. sub buttons of buttonl.

77. Select the layer names as buttonl.

78. Choose Window > Actions.

79. In the Object Actions panel type the following actions.

on (release) {
tellTarget (" _root.menul") {
if (_currentframe <=1) {

gotoAndPlay (2);
}
}
}
"l Object tions oIl
| [Otbrs i
e = 1
% i i (::‘E'I"T:argsjeg ¢ _root.menud”) {
A Operalors if {_currertframz<=1) {
% Furticns y ootoandrlay €23
7] Fropesies
E Objects }} }
[ Unegci Cal .
= @

On button release this action checks the condition ,whether the drop
down movie clip (instance name=menul) is currently at frame 1 or not
If it is then the drop down movie clip starts playing from frame 2.

80. Choose Control > Test Movie.

After clicking the button1 you can see the drop down movie clip playing
and animation of sub buttons forming one by one.

But still we have to make the drop down go reverse. As we are going to
make this happen with the help of ActionScripting, there is no need to
make a reverse animation of sub buttons manually.

Creating Reverse Animation of Drop down Mo

81. Choose Insert > New Symbol.
82. Create a movie clip and name it as 'reverse'.

Symbol Properties

Marme: Ireverse

Behavior. & Maovie Clip Cancel
" Button
™ Graphic Help

i
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83. Rename the layer as 'actions’'.

84. Select frame 1 on the layer named as actions.

85. Choose Window > Actions.

86. In the Frame Actions panel type the following action.
stop ();

87. Now select next frame i.e frame 2.

88. Choose Insert > Blank Keyframe.

89. Choose Window > Actions.

90. In the Frame Actions panel type the following action.
tellTarget (" _root.menul") {

if (_currentframe <=1) {

tellTarget (" _root.reverse") {

gotoAndStop (1);

telse {
gotoAndStop (_currentframe-1);
3 Frame Solions e L
ﬂjl Frame &chons bl I
FRRns wlifceTTTarger ¢ _roov.menul™) {
% if {_currentframe<=1) {
o telltarger ("_root.reverse") |
Funolicns gotdandstop (103
(al F‘?pﬂm T else { N
@ Cbjacs |:I gotoandsStop _currentframa-1);
I }
1] | ¥
Line 1ol 10, ol 1
b &

In reverse movie clip At frame 2 this action checks the condition

whether the drop down movie clip (instance name=menul) is currently

at frame 1 or not.If it is then reverse movie clip stops at frame 1 and

if drop down movie clip is not at frame 1 then it will start playing in

reverse direction.(It will start moving reverse from its current position,

frame by frame.)

i.e. currentframe-1

91. Insert a new layer (Choose Insert > Layer) above the actions layer
and name is as 'labels'.

92. Select frame 2.

93. Choose Insert > Blank Keyframe.

94. Choose Window > Panels > Frame.

95. In the Frame panel type the label name as subbuttonsl1.

[ &l Frafnel )

Lal:ge-'l:.lsubl:-uttn:-nﬂ

Tweening:l Mane _;I
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96. Select frame 3 on the layer names as actions.

97. Choose Insert > Blank Keyframe.

98. Choose Window > Actions.

99. In the Frame Actions panel type the following action.
gotoAndPlay ("subbuttons1");

|50 Frame Aeiiors] &i|w
ﬂj| Frame Actions ¥ |-
@ Actions af fpotosandrTay t"subbut‘tﬂnﬁl"j;
E Operatars
E Functions
E Properiies
@ Obgects o
L
Lirg 1 of 2, Call
i &

/I At frame 3 ActionScript goes back to subbuttons1 label i.e.frame 2

and starts playing from frame 2.

100. Now come back into the main scene i.e. Scene 1.

101. Insert a new layer (Choose Insert > Layer) above the buttonl
layer and rename it as 'reverse'.

102. Select Window > Library > reverse movie clip.

103. Drag the reverse movie clip from the library at layer named as
reverse.

104. The reverse movie clip will look like a small dot in the scene.

Buttonl

105. Select the reverse movie clip.
106. Choose Window > Panels > Instance.
107. In the Instance panel type the Instance name as reverse.

Instance

[2% Jinstance] (7] “
¥ renverze

Echaviar: lr-.-h:--.-ie Clip ;I

Mame: [reverse

L[5 3

Now we have created a movie clip which can animate the drop down
movie clip in reverse direction.But to interact with this reverse movie
clip we have to create a dummy button.
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Creating a dummy button to interact with the re
movie clip

108. Choose Insert > New Symbol
109. Create a button and name it as 'dummy button'.

Symbol Properties B3

Hame: Idumm_l,l bttor Ok I
Behavior: r-“'?"*fiﬁ.:mili' Cancel |
& Huttore ;

{ Graphic ﬂ elp

110. Draw a small rectangle at frame 1 in the dummy button.

’@ Scenel 125 cummy button

B Layer 1

B @ |41 o) &l e

111. Select Window > Library > drop down movie clip.

112. Double click the drop down movie clip to go inside it.

113. Insert a new layer (Choose Insert > Layer) above the actions layer
and rename it as dummy button.

114. Select Window > Library > dummy button (button)

115. Drag the dummy button (button) from the library on the layer
named as dummy button.

116. Choose Window > Panels > Instance.

117. In the Instance panel change the Behavior of the dummy button
from button to a movie clip.

2L Jinstance
'El dhmm.g_!:uutton

Suby Bdttonl

118. Choose Window > Actions.
119. In the Object Actions panel type the following actions.
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