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Dear Friend, 
Hello & welcome back to  your friendly guide to the exciting world 
of web-design & web-solutions!  In this newsletter we are going to make a 
flash photo gallery. This photo gallery contains seven photo thumbnails in a
horizontal scroll which can be operated through the scroll buttons as well as
with toggle keys on the keyboard. By clicking any of the thumbnail in the 
scroll, the big screen will display a full size image of that particular
 thumbnail. Click here to download the source (.fla) file.   

Firewire,

Note To create this flash photo gallery we should have 7 images and their 
respective thumbnails. The main image size should be 424x242 The 
thumbnail size should be 113x62

1. Create a new movie with dimensions of  and  with 
 as background color.

500px X 400px fps=60
white

Movie Properties

http://www.layoutgalaxy.com/html/news41free.zip
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Creating Thumbnail Buttons

We have to create thumbnails as buttons because we have to assign On 
Mouse Event actions on each thumbnail.
1. Choose 
2. Create a Button and name it as 'thumb1'

Insert > New Symbol 

3. Choose 
4. Select the thumbnail you have created and press Open in the Import panel.
5. Rename the layer as 'Thumbnail 1'
6. Insert a new layer (Choose ) above the Thumbnail 1 layer.
7. Draw a rectangle outline as a border of the thumbnail.

File > Import

 Insert > Layer

8. Similarly,create remaining 6 thumbnail buttons and give them names
accordingly i.e thumb2, thumb3, thumb4.......  Now our 7 thumbnail
 buttons are ready.

Let's put them in a row so that they can scroll properly.

Creating Scroll Movie Clip

1. Choose 
2. Create a movie clip and name it as 'scroll'

Insert > New Symbol 

3. Choose  button
4. Drag the thumb1 button from the library on Layer 1
5. Place button exactly at and
    (Choose )
     

Window > Library > thumb1

thumb1 x position=0  y position=0 
Window > Panels > Info
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6. Rename the layer as 'Thumb 1'
7. Insert a new layer (Choose ) above the Thumb 1 layer.
8. Choose button
9. Drag the thumb2 button from the library on newly added layer above
     the Thumb 1 layer.
10. Place thumb2 button exactly at 

(Choose

Insert > Layer
Window > Library > thumb2 

x position=154.6 and y position=0
      Window > Panels > Info)

11. Rename the layer as 'Thumb 2'
12. Similarly drag the remaining buttons and place them on 
      different layers.
13. Select thumb1 button on Thumb 1 layer.
14. Choose 
15. Type the following actions in the Object Actions panel.

 ( ) {
 ("clip1.swf", "_root.screen");

}

Window > Actions.

on release
loadMovie
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* * We will know more about this action in the later part of this 
newsletter. Similarly, assign this action to other thumbnail buttons. Just
 change the name of the loading swf name accordingly i.e for thumb2 -
 clip2.swf , for thumb3 - clip3.swf and so on.
The placings for these buttons are given as below:
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16. Now you can see the thumbnails in one line and at equal distance.
17. Go back into the 
18. Choose  movie clip
19. Drag the scroll movie clip on the stage at 
20. Rename the layer as 'Scroll Movie Clip'.
21. Place the scroll movie clip at  and 
22. Choose 
23. In the Instance panel give an instance name 'scroll' to the scroll 
      movie clip.
      

Scene 1
Window > Library > scroll

Layer 1

x position=97 y position=330
Window > Panels > Instance 

thumb 3

thumb 4

thumb 5

thumb 6

thumb 7

X position= 309 y position=0

y position=0

y position=0

y position=0

y position=0

X position= 463.6

X position= 618.1

X position= 772.9

X position= 927.5

1. Choose
2. Create a Movie Clip and name it as 'left scroll'.

 Insert > New Symbol 

Creating Scroll Handler Movie Clips

3. Select the first keyframe on 
4. Choose 
5. Type following action in the Frame Actions panel. 

 ();

Layer 1
Window > Actions

stop
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// ();
when actionscript enters left scroll movie clip,it will intially stop at
 the first frame. 
6. Select the second frame (next to first keyframe)
7. Choose
8. Choose 
9. Type following action in the Frame Actions panel.
movespeed = 5;

 ( >=97) {
 (1);

}  {
. += moveSpeed;

}

stop

 Insert > Keyframe
Window > Actions

if _root.scroll.
gotoAndStop

else
_root.scroll

_x

_x 

//movespeed = 5;
The 'movespeed' variable value determines the moving speed of the scoll
 movie clip.
// ( >=97) {

 (1);
} {

 += moveSpeed;
}
These actionscript lines check the x position of the scroll movie clip. 
It will check whether the x position of the scoll movie clip is greater than
 or equal to 97.If it is so the actionscript will go back to the first frame 
and will stop there.If the x position of the scroll movie clip is less than 
97 then it will make increment in the x position value of the scroll movie
 clip according to movespeed.This process will stop only when the
 x position of the scroll movie clip reaches to 97.

if _root.scroll.
gotoAndStop
 else 

_root.scroll.

_x

_x
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//movespeed = 5;
The 'movespeed' variable value determines the moving speed of the scoll
 movie clip.
//if (_root.scroll._x>=97) {
gotoAndStop (1);
} else {
_root.scroll._x += moveSpeed;
}
These actionscript lines check the x position of the scroll movie clip. 
It will check whether the x position of the scoll movie clip is greater than
 or equal to 97.If it is so the actionscript will go back to the first frame 
and will stop there.If the x position of the scroll movie clip is less than 
97 then it will make increment in the x position value of the scroll movie
 clip according to movespeed.This process will stop only when the
 x position of the scroll movie clip reaches to 97.

10. Select the third frame (next to second keyframe)
11. Choose 
12. Choose
13. Type following action in the Frame Actions panel.

 (2); 

Insert > Keyframe.
 Window > Actions

gotoAndPlay
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// (2);

This action will help the actionscript to track the x position of the scroll 
movie clip continuously. Once the actionscript enters the second frame 
then after entering the third frame it will go back in the second frame to 
once again check the x position of the scroll movie clip. Similarly we 
want another scroll handler movie clip to help the scroll movie clip to
 move the other way.
14. Choose 
15. Create a Movie Clip and name it as 'right scroll'. 

gotoAndPlay 

Insert > New Symbol 

10. Select the third frame (next to second keyframe)
11. Choose 
12. Choose
13. Type following action in the Frame Actions panel.

 (2); 

Insert > Keyframe.
 Window > Actions

gotoAndPlay
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16. Select the first keyframe on
17. Choose 
18. Type following action in the Frame Actions panel. 

 (); 
19. Select the second frame (next to first keyframe)
20. Choose
21. Choose 
22. Type following action in the Frame Actions panel.
movespeed = 5;

 ( <=-521.4) {
 (1);

}  {
 -= moveSpeed;

}

 Layer 1
Window > Actions

 Insert > Keyframe.
Window > Actions

stop

if _root.scroll.
gotoAndStop

else
_root.scroll.

_x

_x

//  ( <=-521.4) {
 (1);

}  {
 -= moveSpeed;

}
These actionscript lines check the x position of the scroll movie clip. It 
will check whether the x position of the scoll movie clip is less than or 
equal to -521.4.If it is so the actionscript will go back to the first frame
 and will stop there.If the x position of the scroll movie clip is greater
 than -521.4 then it will make decrement in the x position value of the
 scroll movie clip according to movespeed .This process will stop only 
when the x position of the scroll movie clip reaches to -521.4

23. Select the third frame (next to second keyframe)
24. Choose
25. Choose 

if _root.scroll
gotoAndStop

else
_root.scroll.

._x

_x

 Insert > Keyframe.
Window > Actions
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33. Choose 
34. In the Instance panel give an  'left' to the left scroll
       movie clip.

Window > Panels > Instance 
 instance name

26. Type following action in the Frame Actions panel.
 (2); 

27. Go back into the Scene 1
28. Insert a new layer above Scroll layer.(Choose 
29. Rename the layer as 'Left Scroll'.
30. Choose 
31. Drag the left scroll movie clip on the stage at Left Scroll layer.
32. You can place left scroll movie clip anywhere in the scene.

 The left scroll movie clip looks like a dot on the stage.

gotoAndPlay

Insert > Layer)

Window > Library > left scroll

Note:

35. Insert a new layer above Left Scroll layer. (Choose Insert > Layer)
36. Rename the layer as 'Right Scroll'.
37. Choose 
38. Drag the right scroll movie clip on the stage at Right Scroll layer.
39. Like left scroll movie clip ,this movie clip can be placed anywhere
      in the scene.Here we have placed it beside the left scroll movie clip.
40. Choose 
41. In the Instance panel give an instance name 'right' to the right
      scroll movie clip

Window > Library > right scroll

Window > Panels > Instance 

Now we want to create scroll buttons to operate these scroll handler
movie clips.



1. Choose 
2. Create a Button and name it as 'scroll button'.

Insert > New Symbol 
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Creating Scroll Button

3. Here we have used an image of scroll arrow. (Choose 
    to import the arrow image

File > Import)

4. Go back into the 
5. Insert a new layer above the Right Scroll layer.
   (Choose )
6. Rename the layer as 'Scroll Buttons'
7. Choose 
8. Drag the scroll button on the stage Scroll Buttons layer.
9. Place the scroll button next to the third thumbnail button

Scene 1

 Insert > Layer

Window > Library > scroll button

10. Choose 
11. Drag the scroll button on the stage at Scroll Buttons layer.
12. Place the scroll button before the first thumbnail button.
        

Window > Library > scroll button

13. Choose Modify > Transform > Flip Horizontal 
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Now the scroll buttons are ready.We have to give some actions on them
 so that they can interact with the scroll handler movie clips and make
 the scroll movie clip to scroll.

Assigning Actions to Scroll Buttons

1. Select the left side scroll button (facing towards left)
2. Choose 
3. In the Object Actions panel type the following action:

 ( ) {
 ("left") {

 (2);
}
}

 ( ) {
 ("left") {

 (1);
}
}

Window > Actions.

on press
tellTarget
gotoAndPlay

on release
tellTarget
gotoAndStop

//  ( ) {
 ("left") {

 (2);
}
}
On pressing the left scroll button,actionscript will enter in the left scroll 
movie clip (instance name 'left') and will jump to the second frame of that 
movie clip. There it  will process the action given on that frame so that 
the scroll can work.
//  ( ) {

 ("left") {
 (1);

}
}
On releasing the left scroll button,actionscript will jump back to the first
frame in the left scroll movie clip. Due to 'stop' action given on the first
frame in the left scorll  movie clip, the actionscript will do nothing and
the scroll will stop working.
4. Select the right side scroll button (facing towards right)
5. Choose 
6. In the Object Actions panel type the following action:

 ( ) {
 ("right") {

 (2);
}
}

on press
tellTarget
gotoAndPlay

on release
tellTarget
gotoAndStop

on press
tellTarget
gotoAndPlay

Window > Actions.



ht
tp

://
w

w
w

.la
yo

ut
ga

la
xy

.c
om

ht
tp

://
w

w
w

.la
yo

ut
ga

la
xy

.c
om

ht
tp

://
w

w
w

.la
yo

ut
ga

la
xy

.c
om

ht
tp

://
w

w
w

.la
yo

ut
ga

la
xy

.c
om

ht
tp

://
w

w
w

.la
yo

ut
ga

la
xy

.c
om

ht
tp

://
w

w
w

.la
yo

ut
ga

la
xy

.c
om

http://w
w

w
.layoutgalaxy.com

http://w
w

w
.layoutgalaxy.com

http://w
w

w
.layoutgalaxy.com

http://w
w

w
.layoutgalaxy.com

http://w
w

w
.layoutgalaxy.com

http://w
w

w
.layoutgalaxy.com

//  ( ) {
 ("right") {

 (2);
}
}
On pressing the right scroll button,actionscript will enter in the right 
scroll movie clip (instance name 'right') and will jump to the second
frame of that movie clip. There it will process the action given on that 
frame so that the scroll can work. 
//  ( ) {

 ("right") {
 (1);

}
}
On releasing the right scroll button,actionscript will jump back to the first
 frame in the right scroll movie clip. Due to 'stop' action given on the first 
frame in the right scorll movie clip, the actionscript will do nothing and
 the scroll will stop working. To give a  final finishing touch to the 
thumbnail scroll we have put a panel image over the thumbnail scroll.

on press
tellTarget
gotoAndPlay

on release
tellTarget
gotoAndStop

Masking the Scroll Movie Clip

1. Insert a new layer above Scroll Movie Clip layer.(Choose )
2. Rename the layer as 'Mask'.
3. Draw a rectangle patch so that it can cover the 3 thumbnail buttons under it.

Insert > Layer

4. Choose 
5. In the Layer Properties panel click the radio button for

Modify > Layer.
 mask.

on release
tellTarget
gotoAndStop

 ( ) {
 ("right") {

 (1);
}
}
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